Author Topic: Trouble with text codes  (Read 2314 times)

0 Members and 1 Guest are viewing this topic.

Wonderflonium

  • DO NOT BOUNCE
  • Super Hero!
  • ****
  • Posts: 9091
  • I have a PhD in horribleness.
Trouble with text codes
« on: August 11, 2011, 10:32:39 PM »
I've found that if I'm using multiple codes on a block of text (say, bold, increased size, changed color, centered), I have to have the tags in a specific order or they don't all work. Is that the way it's supposed to be? If so, do we have a list somewhere of the correct order?
The status is not quo!

Harriet Jones

  • Super Hero!
  • ****
  • Posts: 6716
  • Yes, we know who you are.
Re: Trouble with text codes
« Reply #1 on: August 11, 2011, 10:39:19 PM »
One problem may be that you're opening and closing the codes in the wrong order. It might work better to close the tags in the reverse order in which you open them.

E.g., (bold)(color)  (/color)(/bold) should work better than (bold)(color) (/bold) (/color)

Wonderflonium

  • DO NOT BOUNCE
  • Super Hero!
  • ****
  • Posts: 9091
  • I have a PhD in horribleness.
Re: Trouble with text codes
« Reply #2 on: August 11, 2011, 10:42:54 PM »
One problem may be that you're opening and closing the codes in the wrong order. It might work better to close the tags in the reverse order in which you open them.

E.g., (bold)(color)  (/color)(/bold) should work better than (bold)(color) (/bold) (/color)

I'm not typing the codes; I'm highlighting the text and using the buttons to apply codes, so they are in the right order.
The status is not quo!

Harriet Jones

  • Super Hero!
  • ****
  • Posts: 6716
  • Yes, we know who you are.
Re: Trouble with text codes
« Reply #3 on: August 11, 2011, 10:47:39 PM »
You can still misorder them that way if you've highlighted one part of a tag and not the other when you're putting other codes in...

Wonderflonium

  • DO NOT BOUNCE
  • Super Hero!
  • ****
  • Posts: 9091
  • I have a PhD in horribleness.
Re: Trouble with text codes
« Reply #4 on: August 12, 2011, 08:17:30 AM »
I highlight the whole string (text and codes already there) before applying the new codes. For example (asterisk added so codes can be seen):

[*size=24pt][*center][*b]Sample text here[/b][/center][/size]

Comes through as

Sample text here
[/size]

However, if I move the size tags so that it's

[*center][*b][*size=24pt]Sample text here[/size][/b][/center]

It comes through correctly as

Sample text here

The status is not quo!

Harriet Jones

  • Super Hero!
  • ****
  • Posts: 6716
  • Yes, we know who you are.
Re: Trouble with text codes
« Reply #5 on: August 12, 2011, 09:43:30 AM »
Ah, ok.  My guess would be that size didn't work because you put it outside center.  The alignment tags probably need to go outside the text formatting tags.

Scritzy

  • Please do not adjust your set.
  • Super Hero!
  • ****
  • Posts: 15895
  • Passing through the iris of the world ...
Re: Trouble with text codes
« Reply #6 on: August 14, 2011, 11:41:19 AM »
I have noticed the codes have to be in order, too, when they are "nested."

Sometimes it takes me a couple of tries to get it right. Thank goodness for Preview!
Dragons

SC
It will pass. Or not.

sparksals

  • Super Hero!
  • ****
  • Posts: 17372
Re: Trouble with text codes
« Reply #7 on: August 25, 2011, 12:26:20 AM »
I have the problem with bolding a sentence in a quote above and it bolds the entire part of the post i bolded PLUS my response.  No matter what I try, it won't allow me to change it.  I have tried turning off bold and redoing just the one sentence, but it bolds everything after what I bolded including my post.  Anyone else have this problme?